Go to Top

 

FAQ SafePUPIL Version 2

I forgot my Username and Password?
Please contact Technical Support Services at 877-792-3866 Ext. 300 between the times of 8:00am – 5:00pm CST Monday through Friday.

I can’t find our company training website?
Click this link to our ClientList The companies are listed alphabetically. Find your company and click that link it will take you to your companies training website.

If your company is not listed please
call client services at 877-792-3866 Ext. 300.

Why are my Videos not playing?
It could be your Download Speed. A minimum of 10 mbps or more is needed to view the videos..

To test your download speed go to speedtest.net.

In Internet Explorer Only.
It could be a Compatibility Issue. To check this.

  1. Right click the top of your browser
  2. Make sure your Menu Bar is checked.
  3. In the Menu Bar select tools a dropdown will show in this dropdown make surethe Compatibility View box is unchecked.
  4. Then in Menu Bar select tools again. Go to Compatibility View Settings, Remove Infinit-i.net if it is in the box, hit OK.

Why are my Test not appearing?
If a test does not appear at the end of a section there could be two things causing this.

  1. First, you may be in the resource center. There is an “assignment page” which includes videos and testing. The resource center is a place to store videos or documents which DOES NOT include testing. Make sure you are on the assignment side when doing training.
  2. The second thing that causes a test not to appear is your using full screen to view the video. You must hit ESC towards the end of the video to take your test.

I can’t hear the videos.
Please follow the steps below:

  1. Click on Start
  2. Go to control panel
  3. Hardware and Sound
  4. Sound
  5. Communications tab
  6. Select the “Do nothing” option
  7. Apply
  8. OK

Windows 7 has a frustrating bug – at times, the volume drops dramatically for no apparent reason, and no matter how high you turn the volume, the sound remains at a very low level. It turns out this problem is caused by a “feature” in Windows 7 that is intended to soften the volume when communication activity is detected. Unfortunately, it activates at other times as well.

Trouble Shooting NO Volume
Please follow the steps below

  1. In the Explorer Window Click on tools.
  2. Go to Internet Options.
  3. Click on the Advance tab.
  4. Scroll down to Multi-Media
  5. Make sure the box is checked next to “Play sounds in webpages”
  6. Apply
  7. OK
  8. Re-start Internet Explorer
  9. Log back into training